Slant *        6        Forum
Home Home Home
The Place to Go for Slant Six Info!
Click here to help support the Slant Six Forum upgrade!
It is currently Mon Jan 27, 2020 8:59 pm

All times are UTC-08:00




Post new topic  Reply to topic  [ 5 posts ] 
Author Message
 Post subject: 225 ... it runs!
PostPosted: Wed May 22, 2019 8:03 pm 
Offline
EFI Slant 6

Joined: Thu Jun 07, 2012 4:29 pm
Posts: 388
Location: Houston
Car Model*:
Well, the worn-out 225 is back together and running. It fired up and, after a dwell adjustment, is running great with zero leaks (yet, lol). It's interesting how this engine, with 0 miles, starts instantly and runs strong. If you didn't know, you'd think the engine had 5,000 miles on it. Not used to that on new rebuilds! It idles at 625RPM with 32 lbs. oil pressure and gets up to 52lbs. with some RPM.

Crank 10/10
Resized rods
ARP rod bolts
SP pistons, .030 over
SP oil pump, deburred and 'ported'
Oregon 818 cam / lifters
RollMaster double roller chain
Rocker Arms Unlimited rebuilt rockers/ hard chromed shaft
Comp Cams springs
SP valves
Hardened exh seats
Smith Bros 3/8 CR pushrods, custom length
Head milled .070
Block milled .020
9:1 CR

Special thanks to Rick Covalt for helping me with a very nice original oil pan. That coulda been a nightmare otherwise.

It's also amazing how bad people let cars get...this car was daily driven right up until the engine gave up. But, just to get it driving I've had to rebuild all the brakes, PS pump, u-joints, rear end seals, radiator, heater core, exhaust system, battery, etc. And the suspension needs it, too. The 904 is also suspect...


Attachments:
225 .JPG
225 .JPG [ 130.89 KiB | Viewed 1716 times ]
225 stand.JPG
225 stand.JPG [ 130.09 KiB | Viewed 1716 times ]
Top
   
 Post subject: Re: 225 ... it runs!
PostPosted: Wed May 22, 2019 8:16 pm 
Offline
TBI Slant 6
User avatar

Joined: Tue Mar 15, 2011 7:56 pm
Posts: 243
Location: Pauls Valley, OK
Car Model*: 1975 Dodge D100
Well done, GregCon! It sounds as if it runs as good as it looks.

_________________
1975 Dodge D100 225 c.i., HEI, Parallel 2 bbl Motorcraft 2150, 727 auto, 9.25" 3.55:1
Image


Top
   
 Post subject: Re: 225 ... it runs!
PostPosted: Thu May 23, 2019 3:26 am 
Offline
Board Sponsor & Moderator
User avatar

Joined: Mon Oct 21, 2002 11:08 am
Posts: 13743
Location: Blacksburg, VA
Car Model*:
Congrats! Enjoy the Slanted driving...

Lou

_________________
"You mean you still have a Slant 6 in that thing?"


Top
   
 Post subject: Re: 225 ... it runs!
PostPosted: Thu May 23, 2019 5:23 am 
Offline
EFI Slant 6

Joined: Thu Jun 07, 2012 4:29 pm
Posts: 388
Location: Houston
Car Model*:
Thanks guys. I just need to get the rest of the car up to standard before I venture onto the concrete jungles of Houston. Around here you can leave a broken down cars on the side of the road for about 3 minutes before 4 or 5 tow trucks arrive whether you like it or not.

Believe me...the hardest part of this project was dropping the shiny, clean engine into the otherwise grungy engine compartment. I scrubbed it up as best I could without dropping the K-frame but there's only so much you can do...


Top
   
 Post subject: Re: 225 ... it runs!
PostPosted: Thu May 23, 2019 5:33 am 
Offline
Turbo Slant 6
User avatar

Joined: Mon Aug 02, 2010 7:36 am
Posts: 890
Location: Rome, GA
Car Model*: 1963 Dart 270, 1980 D150
Well done. Enjoy that good running slant six!

_________________
“Buy the ticket, take the ride.”
― Hunter S. Thompson


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 5 posts ] 

All times are UTC-08:00


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited