Slant *        6        Forum
Home Home Home
The Place to Go for Slant Six Info!
Click here to help support the Slant Six Forum!
It is currently Fri Aug 19, 2022 10:01 pm

All times are UTC-07:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Weird Shift Issue
PostPosted: Thu Dec 21, 2017 7:05 pm 
Offline
4 BBL ''Hyper-Pak''

Joined: Fri Sep 09, 2016 3:46 pm
Posts: 40
Location: Birmingham, AL
Car Model:
Hello, everyone. Looking for some advice on a weird problem. I have a 1985 D100 w/ I believe the A904 auto.

This truck has had this issue for a long time now. The issue is, when in Drive, if I am putting around town slowly at light throttle, it'll shift into 3rd gear by the time it hits 15 mph and will not shift back down until I come to a stop, floor it, or pull the gear selector down into 2. Makes it kind of annoying to drive. I usually have to manual shift it to keep this from happening. Here's where things get weird though...

A couple of weeks ago, I was driving along and all of a sudden, the gas pedal becomes extremely easy to press and the transmission is no longer shifting too quickly, as well as shifting down as needed without having to floor it. Instead, it was shifting down as it should without me having to do anything. It stayed this way for about 1/2 an hour until the throttle got kind of stiff again (like I remember it being all these years) and it's back to short shifting again. EDIT: I need to add this issue does not seem to exist when accelerating at 1/2 throttle or more, but below 1/2 throttle.

I have looked all underneath it at the transmission linkage and everything looks good all the way from the carb back to the trans. I can't understand why when it started shifting correctly, my accelerator became more free??? I can't figure it out. Anyone seen this happen before? Hoping someone can help out. Thanks in advance!

_________________
2007 F-150 5.4L

1985 D100 225 Slant 6


Top
   
 Post subject: Re: Weird Shift Issue
PostPosted: Thu Dec 21, 2017 7:40 pm 
Offline
Supercharged
User avatar

Joined: Sun Nov 03, 2002 9:20 pm
Posts: 12960
Location: Fircrest, WA
Car Model: 76 D100
Check the kickdown lnkage for binding and for proper adjustment.


Top
   
 Post subject: Re: Weird Shift Issue
PostPosted: Fri Dec 22, 2017 5:29 am 
Offline
Supercharged
User avatar

Joined: Sat Feb 16, 2008 1:25 pm
Posts: 5518
Location: Downeast Maine
Car Model:
Defiantly something going on with throttle pressure (kick-down) linkage. Is your linkage made of rods and bell cranks, or cable?

_________________
67' Dart GT Convertible; the old Chrysler Corp.
82' LeBaron Convertible; the new Chrysler Corp
07' 300 C AWD; Now by Fiat, the old new Chrysler LLC

Image


Top
   
 Post subject: Re: Weird Shift Issue
PostPosted: Fri Dec 22, 2017 12:14 pm 
Offline
4 BBL ''Hyper-Pak''

Joined: Fri Sep 09, 2016 3:46 pm
Posts: 40
Location: Birmingham, AL
Car Model:
Thanks for the replies. It has a rod linkage to the transmission. I will try and do some more examining of the linkage to see if it's binding anywhere once it dries up some outside. A few weeks ago though, I didn't see where anything would be binding. Hoping it may just be an adjustment problem. Sure would be nice to take advantage of the convenience of an automatic! I will report back, soon. Thanks!

_________________
2007 F-150 5.4L



1985 D100 225 Slant 6


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC-07:00


Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited