Slant *        6        Forum
Home Home Home
The Place to Go for Slant Six Info!
Click here to help support the Slant Six Forum!
It is currently Wed Jul 28, 2021 8:50 am

All times are UTC-07:00




Post new topic  Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Too Many Volts!
PostPosted: Tue Jul 20, 2021 3:09 pm 
Offline
EFI Slant 6
User avatar

Joined: Wed May 28, 2003 9:08 am
Posts: 295
Location: Austin, TX
Car Model: 71 Dodge D100 64 Plymouth Valiant Wagon
Ran for about 7 or so minutes with the voltmeter pegged, so at least 18 volts. I have the HEI converted system. No spark now. What component should I look at first? What goes wrong w/ 18 volts?

Fuses are all fine.

Thanks,
Joe

_________________
Joe Hoppe

71 D100 225 Super Six 727 AT 3:23 rear
powered by Sweet Lady Propane
64 Valiant Wagon 225 904 AT


Top
   
 Post subject: Re: Too Many Volts!
PostPosted: Tue Jul 20, 2021 3:28 pm 
Offline
Turbo EFI
User avatar

Joined: Mon Jan 12, 2015 5:55 am
Posts: 1187
Location: Brightwood, VA
Car Model: 1965 Plymouth Belvedere I
my bet would be the module. And, likely the voltage regulator.

_________________
-MattMan
Strive for Excellence, not Perfection.
Image


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 2 posts ] 

All times are UTC-07:00


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited