Slant Six Forum
https://slantsix.org/forum/

Too Many Volts!
https://slantsix.org/forum/viewtopic.php?f=28&t=66093
Page 1 of 1

Author:  Daddiojoe [ Tue Jul 20, 2021 3:09 pm ]
Post subject:  Too Many Volts!

Ran for about 7 or so minutes with the voltmeter pegged, so at least 18 volts. I have the HEI converted system. No spark now. What component should I look at first? What goes wrong w/ 18 volts?

Fuses are all fine.

Thanks,
Joe

Author:  Badvert65 [ Tue Jul 20, 2021 3:28 pm ]
Post subject:  Re: Too Many Volts!

my bet would be the module. And, likely the voltage regulator.

Author:  mpgmike [ Sun Aug 29, 2021 11:31 pm ]
Post subject:  Re: Too Many Volts!

I'd start with the basics. First, did you fix the problem that caused 18+ volts? If not, start there (voltage regulator, or the ground to said voltage regulator?). If so, check battery voltage to the module. Next, check distributor signal while cranking. A scope makes that easy, but you should be able to see an analog volt meter needle bounce as a back-up. (Last resort is just use a test light and see if it flickers.) If you have proper battery voltage, solid connection to the ground pin (checked with an ohm meter), pulsing distributor signal, then chances you fried the ignition module. I'd be cautious about possible damage to your instrument cluster 5 volt regulator as well, and any light bulbs that may have been turned on with that high voltage.

Page 1 of 1 All times are UTC-07:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/